Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nexas 7 2013 unable to take or add photos
#1
We just purchased a Nexus 7 for Christmas and purchased Families to snyc with our Legacy application. I can successfully bring over photos from the Legacy app to the Families app on the Nexus. However, I cannot take a photo to link to an individual or pull a photo from the memory to link.

I have Legacy 6.0 loaded on a Windows 7 pc. The Nexus 7 has the latest Android OS 4.4. Is anyone else having this problem?

Thanks
Reply
#2
(31-Dec-2013, 11:17 PM)Eric Carter Wrote: We just purchased a Nexus 7 for Christmas and purchased Families to snyc with our Legacy application. I can successfully bring over photos from the Legacy app to the Families app on the Nexus. However, I cannot take a photo to link to an individual or pull a photo from the memory to link.

I have Legacy 6.0 loaded on a Windows 7 pc. The Nexus 7 has the latest Android OS 4.4. Is anyone else having this problem?

Thanks

Please ensure you've updated to the latest version of Families, 2.0.2.

Malcolm Green
Reply
#3
(01-Jan-2014, 02:27 PM)malgre Wrote:
(31-Dec-2013, 11:17 PM)Eric Carter Wrote: We just purchased a Nexus 7 for Christmas and purchased Families to snyc with our Legacy application. I can successfully bring over photos from the Legacy app to the Families app on the Nexus. However, I cannot take a photo to link to an individual or pull a photo from the memory to link.

I have Legacy 6.0 loaded on a Windows 7 pc. The Nexus 7 has the latest Android OS 4.4. Is anyone else having this problem?

Thanks

Please ensure you've updated to the latest version of Families, 2.0.2.

Malcolm Green

We have the update. At first we could not see pictures on the tablet. Once we applied the update, we could see the photos loaded in Legacy on the tablet. However, with the latest updates, we still cannot take photos or attach photos using the Nexus tablet.

Thanks,

Eric
Reply
#4
(31-Dec-2013, 11:17 PM)Eric Carter Wrote: We just purchased a Nexus 7 for Christmas and purchased Families to snyc with our Legacy application. I can successfully bring over photos from the Legacy app to the Families app on the Nexus. However, I cannot take a photo to link to an individual or pull a photo from the memory to link.

I have Legacy 6.0 loaded on a Windows 7 pc. The Nexus 7 has the latest Android OS 4.4. Is anyone else having this problem?

Thanks

It works OK on my Nexus 7 (original version) with Android 4.4.2. Does anyone else have a problem?

Malcolm Green
Reply
#5
Hi Malcolm

We never could get the picture function to work. We upgraded to Legacy 8, but no success. I am surprised no one else has encountered this problem.

Can I send you any logs or something that you can use to help me figure this out? I can video me trying to add or take a photo if that will help.

I am little frustrated as it seems I am the only one with a photo challenge, yet that is the feature we are most in need of using.

Thanks

Eric
Malcolm

Here is a clip of data from the Families trace log on the Nexus. If you need the entire log, I can send it via e-mail or post it:

17:07:01.802 Getting image for 88
17:07:08.809 Adding image
17:07:08.875 System.NullReferenceException: Object reference not set to an instance of an object
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:07:08.876 Getting marriage 1

17:07:43.759 Getting image for 71
17:07:43.769 Getting image for 72
17:08:00.522 Adding image
17:08:00.686 SQLite.SQLiteException: no such column: PicNameURL
at SQLite.SQLite3.Prepare2 (IntPtr db, System.String query) [0x00000] in <filename unknown>:0
at SQLite.SQLiteCommand.Prepare () [0x00000] in <filename unknown>:0
at SQLite.SQLiteCommand.ExecuteNonQuery () [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Execute (System.String query, System.Object[] args) [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Update (System.Object obj, System.Type objType) [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Update (System.Object obj) [0x00000] in <filename unknown>:0
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:08:00.688 Getting marriage 1
17:08:00.690 Got person from cache 16

17:08:00.838 Getting image for 71
17:08:00.846 Getting image for 72
17:08:09.820 Adding image
17:08:09.854 System.NullReferenceException: Object reference not set to an instance of an object
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:08:09.855 Getting marriage 1
17:08:09.857 Got person from cache 16
17:08:09.857 Got person from cache 15

Thanks

Eric
Reply
#6
(30-Jun-2014, 12:54 AM)Eric Carter Wrote: Hi Malcolm

We never could get the picture function to work. We upgraded to Legacy 8, but no success. I am surprised no one else has encountered this problem.

Can I send you any logs or something that you can use to help me figure this out? I can video me trying to add or take a photo if that will help.

I am little frustrated as it seems I am the only one with a photo challenge, yet that is the feature we are most in need of using.

Thanks

Eric
Malcolm

Here is a clip of data from the Families trace log on the Nexus. If you need the entire log, I can send it via e-mail or post it:

17:07:01.802 Getting image for 88
17:07:08.809 Adding image
17:07:08.875 System.NullReferenceException: Object reference not set to an instance of an object
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:07:08.876 Getting marriage 1

17:07:43.759 Getting image for 71
17:07:43.769 Getting image for 72
17:08:00.522 Adding image
17:08:00.686 SQLite.SQLiteException: no such column: PicNameURL
at SQLite.SQLite3.Prepare2 (IntPtr db, System.String query) [0x00000] in <filename unknown>:0
at SQLite.SQLiteCommand.Prepare () [0x00000] in <filename unknown>:0
at SQLite.SQLiteCommand.ExecuteNonQuery () [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Execute (System.String query, System.Object[] args) [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Update (System.Object obj, System.Type objType) [0x00000] in <filename unknown>:0
at SQLite.SQLiteConnection.Update (System.Object obj) [0x00000] in <filename unknown>:0
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:08:00.688 Getting marriage 1
17:08:00.690 Got person from cache 16

17:08:00.838 Getting image for 71
17:08:00.846 Getting image for 72
17:08:09.820 Adding image
17:08:09.854 System.NullReferenceException: Object reference not set to an instance of an object
at Families_Android.Util_Android.AddImage (Android.Graphics.Bitmap image, Int32 id, Int32 idType, Int32 picOrder) [0x00000] in <filename unknown>:0
17:08:09.855 Getting marriage 1
17:08:09.857 Got person from cache 16
17:08:09.857 Got person from cache 15

Thanks

Eric

Can you confirm that you're using the latest version of Families Sync, 2.0.3? In your earlier posts you mentioned that you were using Legacy 6. I assume that you've now converted your file to Legacy 8. Was this directly from 6 to 8, or did you go via Legacy 7? I think your problem may be related in some way to the conversion.

Malcolm Green
Reply
#7
Hi Malcolm,

We are using the latest release. We did jump from 6 to 8, however, we still have both programs running. We have the image issue on the Nexus with a converted file from Legacy 6 or 8.
Reply
#8
(01-Jul-2014, 02:16 AM)Eric Carter Wrote: Hi Malcolm,

We are using the latest release. We did jump from 6 to 8, however, we still have both programs running. We have the image issue on the Nexus with a converted file from Legacy 6 or 8.

There appear to be 2 problems:

1. When attempting to add a photo to a file created using Legacy 6, the error "SQLite.SQLiteException: no such column: PicNameURL" is generated. We have identified the cause of this and it will be fixed in the next version. Meanwhile, you should avoid trying to add photos to a Legacy6 file.

2. The error "System.NullReferenceException: Object reference not set to an instance of an object". We are unable to reproduce this problem. Please first confirm that this error definitely occurs when using a file created with Legacy 8. If so, please send a copy of the FDB to supportinfo@telgen.co.uk so that we can attempt to reproduce the problem. The data will treated in strict confidence.

Malcolm Green
Reply
#9
(01-Jul-2014, 10:21 AM)malgre Wrote:
(01-Jul-2014, 02:16 AM)Eric Carter Wrote: Hi Malcolm,

We are using the latest release. We did jump from 6 to 8, however, we still have both programs running. We have the image issue on the Nexus with a converted file from Legacy 6 or 8.

There appear to be 2 problems:

1. When attempting to add a photo to a file created using Legacy 6, the error "SQLite.SQLiteException: no such column: PicNameURL" is generated. We have identified the cause of this and it will be fixed in the next version. Meanwhile, you should avoid trying to add photos to a Legacy6 file.

2. The error "System.NullReferenceException: Object reference not set to an instance of an object". We are unable to reproduce this problem. Please first confirm that this error definitely occurs when using a file created with Legacy 8. If so, please send a copy of the FDB to supportinfo@telgen.co.uk so that we can attempt to reproduce the problem. The data will treated in strict confidence.

Malcolm Green

I e-mailed the file today. Thanks. Eric
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)