Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lots and lots of "Illegal characters in path" errors.
#1
I recently got a new laptop and re-installed Families Sync. I went to prepare the transfer file and got 879 errors all of which say "Illegal characters in path." I don't want to sync to my iPad and lose the good transfer I have until I know this transfer won't blow up on me. Here is the transfer info:

09-Mar-2015 15:12:26 Converting C:\Legacy\Data\ADB.fdb written by Legacy 7.5.0.286
09-Mar-2015 15:12:27 Illegal characters in path.
. . .
09-Mar-2015 15:21:46 Illegal characters in path.
09-Mar-2015 15:21:59 Converted C:\Legacy\Data\ADB.fdb to C:\Users\user.domain\Documents\FamiliesSync\ADB.sqlite
09-Mar-2015 15:21:59 -- 879 errors, 5123 individuals, 1818 families, 776 pictures

Am I okay to sync or is there some other problem?
Reply
#2
(09-Mar-2015, 10:29 PM)autumn_dipert Wrote: I recently got a new laptop and re-installed Families Sync. I went to prepare the transfer file and got 879 errors all of which say "Illegal characters in path." I don't want to sync to my iPad and lose the good transfer I have until I know this transfer won't blow up on me. Here is the transfer info:

09-Mar-2015 15:12:26 Converting C:\Legacy\Data\ADB.fdb written by Legacy 7.5.0.286
09-Mar-2015 15:12:27 Illegal characters in path.
. . .
09-Mar-2015 15:21:46 Illegal characters in path.
09-Mar-2015 15:21:59 Converted C:\Legacy\Data\ADB.fdb to C:\Users\user.domain\Documents\FamiliesSync\ADB.sqlite
09-Mar-2015 15:21:59 -- 879 errors, 5123 individuals, 1818 families, 776 pictures

Am I okay to sync or is there some other problem?

We've not seen this problem before. I notice that the fdb file you're converting is a Legacy 7 file. Is this correct or are you now using Legacy 8? If so, you need to change the location of the fdb file to Legacy 8's default - Documents\Legacy Family Tree\Data. If you are indeed still using Legacy 7, please let us know the pathname where your photo files are stored.

Malcolm Green
Reply
#3
I am still on Legacy 7 and my photos are all over the place. Before I found Legacy, I set up my files in a tree beginning with C:\Users\user name\Documents\My Genealogy Files\... I have folders for birth records, death records, etc. in that tree.

Any help would be appreciated!
Reply
#4
(10-Mar-2015, 09:29 PM)autumn_dipert Wrote: I am still on Legacy 7 and my photos are all over the place. Before I found Legacy, I set up my files in a tree beginning with C:\Users\user name\Documents\My Genealogy Files\... I have folders for birth records, death records, etc. in that tree.

Any help would be appreciated!

Please send your fdb file to supportinfo@telgen.co.uk so that we can investigate. The data will be treated in strict confidence.

Malcolm Green
Reply
#5
(11-Mar-2015, 10:02 AM)admin Wrote:
(10-Mar-2015, 09:29 PM)autumn_dipert Wrote: I am still on Legacy 7 and my photos are all over the place. Before I found Legacy, I set up my files in a tree beginning with C:\Users\user name\Documents\My Genealogy Files\... I have folders for birth records, death records, etc. in that tree.

Any help would be appreciated!

Please send your fdb file to supportinfo@telgen.co.uk so that we can investigate. The data will be treated in strict confidence.

Malcolm Green

We've identified the problem, which was caused by a number of invalid entries in the Master Media Folder List (see Options>Customise>Locations>View Current List of Media Folders). In particular the following entry does indeed contain characters which are invalid in filenames:

C:\Legacy\TimeLines\English\US Wars.txt| |2 |0 | |\

There are also several entries which are filenames rather than folder names (e.g. 012.jpg\), and a number of entries commencing a:\, i.e. indicating that the path is to a floppy disk! My suspicion is that you've imported data from some other genealogy program at some time and this has resulted in these rogue entries. I've modified Families Sync (2.1.3) to ignore invalid entries, but it's probably advisable to clean up this list.

Malcolm Green
Reply
#6
Do I need to uninstall and reinstall the Families software to my computer?
Reply
#7
(13-Mar-2015, 11:08 PM)autumn_dipert Wrote: Do I need to uninstall and reinstall the Families software to my computer?

Just update Families Sync - it will detect that there's a new version when you run it.

Malcolm Green
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)