Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Families 2.4.0 + Galaxy S7 with SD card: "no external storage"
#11
(23-Sep-2016, 09:39 AM)cdav Wrote: I don't have that problem with my Sony phone and tablet, I can connect both to the computer via usb cable and (depending on which option I select) can read and write to the SD card and to the phone/tablet's main storage.  Only SD card problem I have is getting families to see it.

Well, after some additional research, I discovered one "solution" discussion that talked about enabling Developer Options, getting there from Settings -> Search.  Turns out Search doesn't get a "hit" on "Developer Options" until you ENABLE developer options.  And you do that by going to Settings -> scroll down to System group -> scroll down to About Phone, scroll down to the "build number" and tap on this item SEVEN TIMES!!!  This unlocks "developer options", and it will now show up as a "hit" in Settings -> Search.

Tap on the "hit" for "Developer Options" from Search, and you'll get a result which is now a blue "developer options" active link.  Tap on this to now get into the set of settings for Developer Options.  First thing, tap on the OFF/ON toggle button to activate Developer Options so that it now shows ON.

Then, scroll down to the Debugging section and tap on the "USB debugging" item to turn it ON.

Then scroll down further to the Networking section and tap on the "USB configuration" item to produce a popup which now offers Charging at the top and MTP (Media transfer protocol) as the second item.  Tap on that second item.  Note that in my opinion, this is actually what already shows as "file transfer" (which is the second item) in the standard USB configuration menu when you pull down the notify/status bar after plugging in the phone via USB cable and it shows "charging" here.  By tapping on that item in the notifications you get into USB confiuguration and can tap on that second "file transfer" item.  I suspect this is actually the same thing I somehow just activated through all of this "developer options" stuff, which I'm not really sure is necessary.  It probably would have helped if it actually displayed as MTP (media transfer protocol) in the standard USB configuration pulldown (as it did in the S4) rather than simply "file transfer".

Anyway, after tapping on "MTP" in the USB configuration of Developer Options, when returning to the previous page it still shows as "Charging", even though if you tap on it again it will truly show "MTP" which you selected. Distracting.  However if you restart the phone, and repeat all of the above process to get down to this point, now it will actually show "MTP" in the "USB configuration".  Ok.  But again, I'm not convinced this whole process is really any different from just choosing "file transfer" on the standard normal USB configuration pulldown from the notify/status bar.

Ok... time to test this out, and see if I can actually transfer files from the phone to PC.  Plug in the phone via USB cable, and lo and behold Windows starts installing drivers (which it obviously had not installed previously, even though I'd gone through this yesterday and it DID install MTP driver).  But today it did something additional, and that was to install Samsung ADB driver.  Hmmm..

Now, can I actually transfer a file from phone to PC?  The answer is NO!!!  Still locks up.

Ok, I continue reading more posts on the original Androidcentral.com forum thread which had been my source of information regarding connectivity problems, and discovered this seemingly ridiculously simple suggestion:

Its the cable. A Galaxy S7 can detect the type of cable and will only charge on lower quality cables, not allowing file transfers.

Try a different (better) usb cable.


Well, I suddenly realized there might be something to this seemingly ridiculously simple thought.  In fact, I had been using the USB cable from my S4 for this computer connection, as my USB cable that came with the S7 was downstairs in the new Adaptive Fast Charger plugged into the wall, where I normally charge the phone.

So I went downstairs to retrieve that S7 USB cable and brought it back to the computer, swapping it for use instead of the old S4 USB cable I'd been using.

And son of a gun, my mouth dropped open when I COULD ACTUALLY NOW READ/WRITE FILES BETWEEN PHONE AND PC!!!  Apparently it probably was the USB cable all along!!!  I probably never needed to go through all of that developer options stuff.  I'd been correctly tapping on the "file transfer" item in the normal USB Configuration pulldown (since the phone always starts in "charging" mode), but had been using the old/wrong S4 USB cable.  Apparently there's something in the new S7 USB cable that the phone detects, that is crucial to doing file transfers to PC.

So, I would have to say CASE CLOSED!!!  It was probably the cable all along.  I suppose I really could prove this (which I probably will) by un-doing all that I'd done through Developer Options, and just putting this all back to standard out-of-the-box default setup.  I know that I must tap "file transfer" for the standard USB configuration pulldown to change from "charging", but that's very similar to how the S4 worked.  It always initially connected in "installer" mode and I had to tap on "MTP".  So Verizon/Samsung have changed words to confuse us, and now it starts in "charging" mode and I have to tap on "file transfer". But it probably is the identical result.

The key seems to be to use the S7's USB cable and not any other!!!

HOORAY!  I no longer need to remove the SD card and put it in a standalone USB card reader to read/write.  I can once again talk to it while installed in the S7 phone.  HOORAY!!
Reply
#12
I've had that problem with some USB cables too. There appear to be two different types, ones that just charge and ones that also allow data transfer. I suspect the former is missing a wire or connection, probably so the manufacturer can save a bit of money. When I find I have one of these I throw it away as I've got so may usb cables from old phones etc that will do file transfers, there doesn't seem much point in keeping the other type.

However, that still doesn't solve the problem of getting families to recognise the SD card on my tablet and phone, so I still have it taking up precious internal storage (although I must say the writers of families have done a fantastic job of keeping the data files small, a Legacy file with pictures that takes over 1GB takes up less than 200MB as a families file, which is smaller than the original Legacy database without the pictures).
Reply
#13
(29-Sep-2016, 02:27 AM)cdav Wrote: I've had that problem with some USB cables too. There appear to be two different types, ones that just charge and ones that also allow data transfer. I suspect the former is missing a wire or connection, probably so the manufacturer can save a bit of money.

I'd never run across this with my S4.  I was able to do file transfers using that cable, which was the same one I used to charge with via the charger block that came with the phone and cable.

It was only with the S7 that Samsung clearly must have made a change to the cable that the S7 can detect, and that also supports the new "adaptive fast charging" capability of the new charger block that comes with the S7.  The S7 will charge-only with the S4 cable, but will not file transfer across it.  The S7 cable can be used for both purposes.

I don't have a problem with this.  I simply didn't know about it until the other day.  Since sticking with the S7 cable for everything I have complete freedom to both READ and WRITE to both internal phone and SD card storage problem-free between the phone and PC.
Reply
#14
(22-Sep-2016, 08:12 AM)admin Wrote: I've researched this problem on the web, and it appears to be caused by a fundamental change in the way in which external storage is handled in Android 6.  The path to the SD card is no longer fixed, but contains numbers which vary from one device to the next.  Many other app developers have hit the same issue.  We will need to redesign the way we handle the SD card and this will take some time.  Meanwhile it will be necessary to use internal storage if using Android 6.

Malcolm Green

Well, "it's a miracle". Even though ABOUT on my S7 phone still shows the same 2.4.0 version for Families, the inability to access the SD card is no longer an issue!!  Furthermore, the Kennedy Family file issue (where it cannot be deleted) has also disappeared!

And yet, the program version still shows 2.4.0, suggesting there has been no update since my original September post on this forum.  Surely something must have changed in the interim, and it is most likely that a program update must have been pushed out with no version change.

Anyway, I can now "check" the "use SD card storage" option, and it apparently works silently and properly.  No popup error about "no SD storage present".  Instead, the check just remains.

Then, if I relaunch the program all I see is the Kennedy Family.  My own Sperber Family file is not shown.  This would be expected in a newly created Android\DATA\ Telgen folder on the SD card.

I then did a SYNC from PC to phone via USB, and I was advised that the file had been written to the SD card.  I checked, and sure enough my Sperber Family file was now on the SD card where I would expect to find it.

I then launched Families on the phone, and sure enough both Kennedy and Sperber family files were listed.  I tapped on my Sperber family and sure enough the very latest data and pictures were there, so the PC obviously had sync'ed properly with the phone.

I then deleted the Kennedy file from the SD card, and re-launched Families.  Sure enough, now just my Sperber family file is listed.

I then deleted the Android\DATA Telgen folder on the internal phone storage, and relaunched Families.  No change, just as expected.

It's obvious to me that [somehow, magically] Families 2.4.0 is now working properly in terms of being able to access SD card storage on the latest same Android 6.0.1, security patch date Sept 1 2016, on my S7 phone.  Also, the reported Kennedy Family file problem (where it would keep getting re-created after I had deleted it) also seems to have been resolved.  I would have expected any program corrective update to at least to produce a newer version number, like 2.4.1, and yet that didn't happen.

Hence "it's got to be a miracle".  (surely not!)
Reply
#15
We're glad this is now working correctly for you.

2.4.0 was released on 13 October - the previous version, on which you encountered the problem, was 2.3.0.

Malcolm Green
Reply
#16
(17-Oct-2016, 03:51 PM)admin Wrote: We're glad this is now working correctly for you.

2.4.0 was released on 13 October - the previous version, on which you encountered the problem, was 2.3.0.

Malcolm Green

Strange.  I was sure I'd checked the version before posting the title of this thread back in September, but apparently I wasn't seeing it correctly or perhaps just made a typo.  I knew you'd surely have a new version if you pushed out a correction.  Obviously that makes sense.

Anyway, thank you again very much for working on this issue and correcting it amazingly promptly.  You're a shining example of a software author/vendor who takes a "parental and proud interest" in his very fine product that does exactly what it claims to do, pays attention to his own online support forum, and responds appropriately to user reports of genuine problems, questions, and issues.

Not to rant much, but this thread's interaction between user and author demonstrates the exact OPPOSITE of the attitude of the author/vendor of MailDroid Pro (my email app on my Galaxy S7 phone) where I've reported and documented at least five MAJOR functional and GUI bugs over the past two years, ALL OF WHICH remain un-fixed.  In fact, instead of fixing the bugs (I would be satisfied if he just eventually worked his way down the list, but he simply ignores them) he's condemned me for "writing emails and forum posts with too many words", actually BANNED me from his so-called support forum, and no longer responds to my emails to his "support address".  I mean, if your email program supposedly handled ICS (calendar) attachments but placed the WRONG TIME (off by 5 hours) in your Google Calendar, would you just leave it broken???

Ok.  Off-topic, I know.  It's really just my way of thanking you again for your professionalism.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)