Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pictures
#1
How do I add an existing picture down loaded from Legacy to a new individual?
Reply
#2
(29-Mar-2017, 05:07 PM)Andy MC Wrote: How do I add an existing picture down loaded from Legacy to a new individual
That's not currently possible.  You'd need to transfer it again from the PC.  I'll think about how this could be achieved for a future version.  Possible we could add another "Add Photo" option to the existing options allowing using the camera or selecting from the photo gallery, e.g. by displaying a special photo gallery of all the photos in the family file.  Or possibly a more efficient and easier to implement solution would be to provide a "save to clipboard" option on the Photo View and a "load from clipboard" on the Add Photo option.  Please let us know if you have a better suggestion.
Malcolm Green
Reply
#3
Thanks for your reply.
My immediate response was that I was looking for a copy and paste type option.
Further thoughts made me wonder how Legacy would cope when data is written back to it?
My images are not all kept in one folder. I have 1841,1851,1861,1871,1881,1891,1901 &  1911 census as well as certificates and photographs all in separate folders.
If a new image is added in Families where will it arrive in Legacy?  Will it be in a new folder?
Similarly if we have a copy and paste option will Families create a second copy and where will it finish in Legacy?
Not quite as simple as it first appears!
Regards
Andy
Reply
#4
Thought I would do some testing.
Transferred Legacy to Families without any pictures.
Added a picture from picture file to individual in Families.
Transferred Families to Legacy produced the following error
Failed to write new picture to [Family File Folder]\Documents\Family Tree\02042017194332.jpg
Where do I go from here?
Andy
Reply
#5
Another observation.
Having attached the picture to the individual there is no thumb nail shown in family view. However clicking on the icon shows the image as you would expect.
Andy
Reply
#6
(01-Apr-2017, 12:22 AM)Andy MC Wrote: Thanks for your reply.
My immediate response was that I was looking for a copy and paste type option.
Further thoughts made me wonder how Legacy would cope when data is written back to it?
My images are not all kept in one folder. I have 1841,1851,1861,1871,1881,1891,1901 &  1911 census as well as certificates and photographs all in separate folders.
If a new image is added in Families where will it arrive in Legacy?  Will it be in a new folder?
Similarly if we have a copy and paste option will Families create a second copy and where will it finish in Legacy?
Not quite as simple as it first appears!
Regards
Andy

I agree that a copy/paste option looks like the best solution.  With this approach, copying an existing photo to a different individual or event would simply copy the reference to the photo rather than the photo itself, so no new photo would be copied back to Legacy.  If you add a new photo from the camera or gallery, it will be copied back to Legacy and stored in the folder specified in Legacy's 6.1 option - Default location of family files.

Regards,
Malcolm
Reply
#7
(03-Apr-2017, 04:18 PM)Andy MC Wrote: Thought I would do some testing.
Transferred Legacy to Families without any pictures.
Added a picture from picture file to individual in Families.
Transferred Families to Legacy produced the following error
Failed to write new picture to [Family File Folder]\Documents\Family Tree\02042017194332.jpg
Where do I go from here?
Andy

As I said in my previous post, a new picture should be written to the folder specified in Legacy's 6.1 option - Default location of family files.  I've only ever seen this set to a fully specified folder path, e.g. C:\Users\mgreen\Documents\Legacy Family Tree\data, but in your case the path includes a "logical" string [Family File Folder], which Families Sync will need to translate to its physical equivalent.  I'll update FS accordingly.

Regards,
Malcolm
Reply
#8
(03-Apr-2017, 10:04 PM)Andy MC Wrote: Another observation.
Having attached the picture to the individual there is no thumb nail shown in family view. However clicking on the icon shows the image as you would expect.
Andy

I've not been able to reproduce this.

Malcolm
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)